Chili DirectX Framework

The Partridge Family were neither partridges nor a family. Discuss.
Post Reply
UwUest Baka
Posts: 1
Joined: May 18th, 2021, 12:33 pm

Chili DirectX Framework

Post by UwUest Baka » May 18th, 2021, 12:40 pm

Hi,Mr. Chili
So i just started the tutorial n when i tried to build the Chili DirectX Framework in Visual Studios 2019
"Build started...
1>------ Build started: Project: Chili DirectX Framework, Configuration: Debug Win32 ------
1>LINK : fatal error LNK1104: cannot open file 'dxerr.lib'
1>Done building project "Chili DirectX Framework.vcxproj" -- FAILED.
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped =========="
this popped up, I already set my SDK version to Windows 10 n my platform toolset to Visual Studio 2019(v142) but it still doesn't work.
so i would really love some help, thanks in advance

Posts: 4317
Joined: February 28th, 2013, 3:23 am
Location: Oklahoma, United States

Re: Chili DirectX Framework

Post by albinopapa » June 5th, 2021, 9:16 am

Sounds like you might have downloaded the old framework. Where did you download it from? dxerr.h and dxerr.dll were part of the June 2010 DirectX SDK if I recall correctly, but I may be mistaken. In the newer framework from 2016 ( the other one was from like 2012 ) has chili modified versions of dxerr.h and dxerr.cpp.

The error message you are getting is because in the project properties dxerr.lib is listed as a file to link to. If you are starting from the beginning, you won't even need this file. The best solution is to download the version from GitHub.
If you think paging some data from disk into RAM is slow, try paging it into a simian cerebrum over a pair of optical nerves. -

Post Reply