Register    Login    Forum    Search    FAQ

Board index » Everything




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: performance problems
 Post Posted: January 5th, 2018, 10:13 pm 
 

Joined: December 25th, 2017, 7:14 pm
Posts: 2
hey im trying to make a simple 2d shooter using the framework and i ran into some performance issues.
does anyone else got any performance issues using the framework?
im developing it on two different pc's.
my laptop:
intel core i5 6200u 2.4Ghz
8GB ram
and my desktop:
intel core i7 4790k 4.0Ghz
16GB ram
nvidia geforce gtx 970 4GB

and i got performance issues on both, when trying to load more than 15 sprites 40x40 or when trying to make a background which is a 600x800 sprite.
it will be very nice if someone could help and tell me if it is a problem with the framework or it might be my own code.
thanks in advance.


Top 
 Profile  
Reply with quote  
 Post subject: Re: performance problems
 Post Posted: January 6th, 2018, 7:18 am 
 

Joined: February 28th, 2013, 3:23 am
Posts: 2908
Location: Oklahoma, United States
What kind of performance issues, long load times? low fps?

Have you made sure you are in Release mode and not Debug mode?

If you get long load times or low fps in Debug mode, then there is probably no issue as this is probably going to be normal. If you have long load times for 15 40x40 and a 800x600 image or low fps in Release mode, there may be an issue, but I couldn't even begin to debug it without having a copy of the project. Open a free GitHub account, upload your project there and post a link to your repo here on the forum and me or someone else can help take a look.

_________________
If you think paging some data from disk into RAM is slow, try paging it into a simian cerebrum over a pair of optical nerves. - gameprogrammingpatterns.com


Top 
 Profile  
Reply with quote  
 Post subject: Re: performance problems
 Post Posted: January 6th, 2018, 11:49 pm 
 

Joined: December 25th, 2017, 7:14 pm
Posts: 2
hi thanks for helping me.
in release mode it does returns to 60 fps but do you might have any idea why is it so slow on debug mode?
on my laptop it run only in 7 fps on debug mode.
and i dont have access to my desktop right now to check it on stronger hardware.

heres a link to the project anyway
its my first project and its only in early stages
you move with the arrows and shoot with x
https://github.com/alloncm/SomeWierdGame


Top 
 Profile  
Reply with quote  
 Post subject: Re: performance problems
 Post Posted: January 7th, 2018, 12:57 am 
 

Joined: June 26th, 2012, 5:38 pm
Posts: 767
Location: USA
Debug mode has all kinds of (extra) stuff going on. Always test performance in release mode and use debug mode for debugging.

_________________
Computer too slow? Consider running a VM on your toaster.


Top 
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
 
Post new topic Reply to topic  [ 4 posts ] 

Board index » Everything


 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron