Register    Login    Forum    Search    FAQ

Board index » Everything




Post new topic Reply to topic  [ 15 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Git problem.
 Post Posted: July 23rd, 2017, 6:09 am 
 

Joined: August 2nd, 2016, 12:34 am
Posts: 21
Location: Russia, SPb
Hey guys. I can not send changes to the newly created repository


Attachments:
photo_2017-07-23_09-08-17.jpg [94.48 KiB]
Not downloaded yet
Top 
 Profile  
Reply with quote  
 Post subject: Re: Git problem.
 Post Posted: July 23rd, 2017, 6:46 am 
 

Joined: February 28th, 2013, 3:23 am
Posts: 2782
Location: Oklahoma, United States
You are trying to push changes to chili's repository and you do not have that privilage.

  • Go to chili's GitHub, find the Snek repositor and click on Fork. This will copy his repo to your account.
  • Then in Visual Studio on the Team Explorer tab, open the snek repo/solution.
  • Click on the Home icon and then on the Settings button.
  • Click on the Repository Settings link.
  • Down near the bottom, you can change the Remotes settings. Change the addresses so they point to the repository in your GitHub account

_________________
If you think paging some data from disk into RAM is slow, try paging it into a simian cerebrum over a pair of optical nerves. - gameprogrammingpatterns.com


Top 
 Profile  
Reply with quote  
 Post subject: Re: Git problem.
 Post Posted: July 23rd, 2017, 8:14 am 
 

Joined: August 2nd, 2016, 12:34 am
Posts: 21
Location: Russia, SPb
nonono, I completely follow the video) I created a new repository on my account and try to send a branch there. If I sent to the repository, I would get another error, I specifically checked


Top 
 Profile  
Reply with quote  
 Post subject: Re: Git problem.
 Post Posted: July 23rd, 2017, 9:10 am 
 

Joined: February 28th, 2013, 3:23 am
Posts: 2782
Location: Oklahoma, United States
Look at the error, "Error encountered while pushing branch to remote repository:..."with error 403 which is unauthorized access. Plus the repository address you are pushing to is https://github.com/planetchili/snek.git and https://github.com/planetchili/poo_game.git so the repositories are trying to push to chili's repos, and not your own.

_________________
If you think paging some data from disk into RAM is slow, try paging it into a simian cerebrum over a pair of optical nerves. - gameprogrammingpatterns.com


Top 
 Profile  
Reply with quote  
 Post subject: Re: Git problem.
 Post Posted: July 23rd, 2017, 9:15 am 
 

Joined: August 2nd, 2016, 12:34 am
Posts: 21
Location: Russia, SPb
albinopapa, thx for replies, but it's log) It's previous attempts with chili's repo. Sorry that I disoriented you. When my error appears, the VS writes ONLY the error that the one on the right, output does not change.


Top 
 Profile  
Reply with quote  
 Post subject: Re: Git problem.
 Post Posted: July 23rd, 2017, 10:11 am 
Site Admin
User avatar

Joined: December 31st, 2011, 4:53 pm
Posts: 3448
Location: Japan
Post another shot with the actual error, and give link to your repo.

_________________
Chili


Top 
 Profile  
Reply with quote  
 Post subject: Re: Git problem.
 Post Posted: July 23rd, 2017, 8:42 pm 
 

Joined: August 2nd, 2016, 12:34 am
Posts: 21
Location: Russia, SPb
https://github.com/baevpetr/Snek_game


Attachments:
after.jpg [69.47 KiB]
Not downloaded yet
before press push.jpg [71.47 KiB]
Not downloaded yet
repos.jpg [71.2 KiB]
Not downloaded yet
Top 
 Profile  
Reply with quote  
 Post subject: Re: Git problem.
 Post Posted: July 24th, 2017, 6:01 am 
User avatar

Joined: May 23rd, 2013, 3:52 pm
Posts: 1235
Location: USA
  • Go to branches
  • Right click your branch
  • Click Publish Branch

_________________
always available, always on, about ~10 years c/c++, java[script], win32/directx api, [x]html/css/php/some asp/sql experience. (all self taught)
Knows English, Spanish and Japanese.
irc://irc.freenode.net/#pchili alt -- join up if ever want real-time help or to just chat :mrgreen: --


Top 
 Profile  
Reply with quote  
 Post subject: Re: Git problem.
 Post Posted: July 24th, 2017, 6:09 pm 
 

Joined: August 2nd, 2016, 12:34 am
Posts: 21
Location: Russia, SPb
I can not) I can only get an obvious error about the fact that the remote repository is not my.


Attachments:
123.jpg [247.77 KiB]
Not downloaded yet
Top 
 Profile  
Reply with quote  
 Post subject: Re: Git problem.
 Post Posted: July 24th, 2017, 11:04 pm 
 

Joined: February 28th, 2013, 3:23 am
Posts: 2782
Location: Oklahoma, United States
try removing chili's repo from the settings, instead of having to remotes, make yours the only one listed.

_________________
If you think paging some data from disk into RAM is slow, try paging it into a simian cerebrum over a pair of optical nerves. - gameprogrammingpatterns.com


Top 
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
 
Post new topic Reply to topic  [ 15 posts ]  Go to page 1, 2  Next

Board index » Everything


 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for: